The DeltaLog9 application allows you to manage HD21xx, HD31xx, HD32.7, HD32.8.8 and HD32.8.16 simply and intuitively from your PC. If you use dataloggers, recording can be started and stopped and all the data contained in the instrument's memory can be downloaded directly from your PC. On all models, the instrument’s parameters can be set, the data can be displayed as a table or a graph, the measurements detected by the instrument can be displayed and saved to file in real time, the data can be printed and exported in PDF, Word® and Excel® format, and the battery's charge status can be read…
Note: some DeltaLog9 functions vary according to the instrument connected. When necessary, the differences are pointed out.
The software is equipped with an automatic search function for the devices connected to your computer.
1) Connect:
HD21xx.1 to a serial port (COM), using the cable HD2110CSNM, or to an USB port, using the cable C.206.
HD21xx.2 to a USB port, using the cable CP23, or to a serial port (COM), using the HD2110CSNM serial cable.
HD31xx to a USB port using the cable CP31.
HD32.7 and HD32.8 to a serial port (COM) through the 9CPRS232 cable or to a USB port through the CP22 cable.
2) Start the application by double clicking on the application icon on the desktop, or select the DeltaLog9 item in the DeltaOhm folder on the Start menu.
3) Select the Port settings command from the Option menu.

4) For the HD21xx.2 models connected to a PC's USB port using the CP23 cable, select the USB-HID for series HD21 connection type.

For the HD31xx models select the USB-HID for series HD31 connection type.

In all other cases, select the Serial: RS232/USB connection type.

5) For the USB-HID for series HD21 and USB-HID for series HD31 connection types, select the desired device in the HID Device drop-down list, if more devices are connected.

For the Serial: RS232/USB connection type, select Auto detect to let the software automatically search for an instrument connected to the PC (recommended option); alternatively, deselect the Auto detect option and select the number of the COM port to which the instrument is connected, than set the Baud Rate equal to that configured in the instrument (default 38400).

6) Press OK to return to the main window.

7) Press the Connect button or select the Connect command from the Instrument menu.

After successful connection, the page showing the instrument basic information and, to the lower right, the Connected indication will appear:

A failed connection will be indicated by the following indication:
![]()
Note: if the Auto detect option is selected and there are no instruments connected to COM ports, but there is an instrument connected in HID mode, the software will connect to the HID instrument.
To end a communication session with the instrument, press the Disconnect button or select the Disconnect command from the Instrument menu.

If the application is unable to connect to the instrument please refer to the Trouble shooting section in this manual.
![]() |
Caution: except for HD31xx, the keyboard of the instrument connected to the PC is disabled and it is not possible to use it: to restore the normal functioning, disconnect the instrument by pressing Disconnect. |
This feature downloads the data acquired using the Logging operation and contained in the instrument memory to the computer. The data can then be displayed on the monitor of the PC. The data downloaded to the PC are not deleted on the memory of the instrument: this is performed by the Clear Instr. Mem. command in the Instrument menu.
|
|
To download the data contained in the datalogger memory, connect the instrument to the PC using the appropriate USB or serial cable, turn on the instrument, launch the DeltaLog9 application, connect the instrument (Connect button). |
|
|
Press the Download data on PC button (note: the button is disabled if logging is in progress). |
For the models HD21xx.2, HD32.7 and HD32.8, pressing the button transfers the instrument entire memory directly to the PC. It is possible to see the file download progress in the "Download Status" window and to interrupt the operation with the Cancel Download button. Upon completion of the download, the different measurement sessions will be shown in the report list.
For the models HD31xx, wait for the instrument to go into MSD (Mass Storage Device) mode, that is necessary for the program to read the files stored in the SD card of the data logger, then select the files you want to be copied. To select all the files, press the Sel. All button. By default, the data are downloaded in D31 format; to download the data in CSV and/or PDF format as well, select the corresponding options. Press the Browse... button to choose the folder where to copy the files. Press the Download button to copy the selected files. The transfer progress is highlighted by the bar in the lower part of the window.
Note: when the transfer window is closed, the HD31xx data logger returns from MSD mode to normal operation mode (HID); if the program doesn't succeed in returning the data logger to HID mode, simply disconnect and reconnect the CP31 USB cable. |
|
|
|
Press the Disconnect button to disconnect the instrument. Unplug the serial/USB cable. |
The steps to set the instrument up, and start and stop logging with DeltaLog9 are now outlined.
The following procedure sets the immediate recording:
![]() |
Connect the instrument to the computer. Turn on the instrument and launch the DeltaLog9 application and click on Connect. |
![]() |
After successful connection, press Start Recording: |
|
|
The window with the current settings will appear. For the models HD21xx.2, HD32.7 and HD32.8, the
current status of the following parameters is reported:
For the models HD31xx, the sampling interval and the log selection status of each channel are reported (ON=channel selected, OFF=channel not selected). Only the selected channels (ON) will be logged.
If no changes are needed, by pressing Start the recording is started immediately. If you wish to change the recording parameters, by pressing Setup the Setup window appears so that the parameters can be modified. NOTE: recording is started automatically after 10 seconds, even without pressing Start. The time remaining before start of function is visible in the title bar. |
![]() |
To end the logging, press Stop Recording. |
|
|
Press the Disconnect button to disconnect the instrument. Then unplug the serial/USB cable. |
Note: recording can be stopped by pressing the LOG (HD21xx.2) or MEM (HD32.7 and HD32.8) key on the instrument one minute after disconnection of the serial or USB cable. With HD31xx the recording can be stopped by selecting the STOP command.
DeltaLog9 appears after the data has been downloaded and a saved file has been opened, as in the following window:

The following functional areas can be seen:
1. |
Data Window: it displays the report in graphical form. |
2. |
Main Menu: it collects the menu items. |
3. |
Command Bar: a set of icons corresponding to the main commands of the application. |
4. |
Report or File List: area in which the downloaded reports or files are summarized: each report or file represents a data session. |
5. |
Graph settings: it changes the properties of the selected graph. |
6. |
Status Bar. |
| 7. | Connection Status of the serial or USB port. |
The Report or File List shows the file corresponding to the different logging sessions with the start date of each capture, the number of recorded samples (only HD21xx.2, HD32.7 and HD32.8) and any notes entered by the user (only HD21xx.2, HD32.7 and HD32.8). To select a file you only need to use the left button of the mouse to click on its name in the report or file list. If the Open Report in multi windows option is selected, a new Data Window is opened each time a Report/File is selected. If the Open Report in multi windows option is not selected, only the graph of the last Report/File selected will be displayed.

The graph of the measurements, as detected by the instrument, is shown in the Data Window. The displayed quantities and the units of measurement are shown in the upper part of the window. The date and time shown in the window indicate the starting time of the displayed trend.

By moving your mouse pointer over a graph, a label indicates the values of all the quantities of the graph at the pointer position.

The standard setting displays all available channels: to display only some channels, use the Graph Properties command. In the window that will open select the desired variable or variables. To restore the display of all channels, repeat the procedure and select all channels.
A note which will be recorded with the file can be associated to each report. Enter the note in the NOTE field at the bottom of the window.

To save the file with the notes, select the command Save as....
Graph
zoom and shift:
To enlarge a specific area of the graph, press the "Zoom +"
button or select the "Zoom +" command in the Tool
menu.

The mouse pointer takes the form of a magnifying glass. Press the left key of your mouse and point the cursor at an extremity of the area to be enlarged and, always keeping the key depressed, drag the mouse to draw a box around the area of interest, then release the key.

The zoom function remains active, so several zooms can be performed in sequence with no need to press each time the "Zoom +" key. To disable the zoom function, press again the "Zoom +" key.
To reduce the zoom action on an enlarged area, press the "Zoom -" button or select the "Zoom -" command of the Tool menu.

To apply more precisely a zoom, open the following Zoom window by selecting the Zoom settings button in the Tool menu:

Select the panel where you want to change the zoom (click with the left key of your mouse inside the panel), the values in the Zoom window are updated with those of the selected panel. Enter the desired minimum and maximum values for the axes of the ordinates ( Y axis is the one on the graph left, while Y2 is the one on the right) and the starting (Start) and final (Stop) time of the axis of the abscissas (X axis). Press the Apply Zoom button to make the new zoom effective.
To shift vertically and/or horizontally the graph, press Move graph button or select Move graph command in the Tool menu. The horizontal shift is possible only if a zoom has been applied to the graph.

Graphs
and tables:
To go from the data display mode in graph form to that in table form, select
the panel where you want to change the display mode (click with the left key
of your mouse inside the panel) and press View Table button or select
View Table command in the View menu.


If during logging or data transfer, the instrument goes in error, the corresponding string reports the error indication in place of the measurement, using one of the following labels:
These indications are the same appearing on the instrument display: please see their description in the instrument manual.
To simultaneously view data in graph and table form, press the button View Graph and Table or select the command View Graph and Table in the View menu.

When graph and table are simultaneously displayed, moving the cursor in the graph causes the automatic scrolling of the table.

To return to the graph display only mode, press the View Graph button or select the View Graph command in the Tool menu.

Changing
graph properties:
To change the properties of graphs, press the button Graph Properties or
select the command Graph properties in the Tool menu.

The window for graph settings opens.

In the program main window, select the
graph you want the properties to be changed (click with the left key of your
mouse inside the graph), the properties indicated in the window are updated
with those of the selected graph.
The column Channel shows all the quantities available for viewing.
To display or hide a quantity in the graph, select or deselect respectively
the box in the View column in correspondence with the line of the quantity.
To change the color of a quantity, select the Col. (Color) column in
correspondence with the line of the quantity, then select the desired color
in the drop-down list.

To change the style of the line that represents a quantity, select the column Line in correspondence with the line of the quantity, then select the desired style in the drop-down list.

To change the quantity represented by
the axis of the ordinates at the right of the graph, select it in the column
On Y2 (select only one quantity in that column).
To display or hide the grid of the graph, select or deselect respectively the
option Display grid.
To highlight or hide the points that correspond to the measured values, select
or deselect respectively the option Display points. The style
of the points referred to a quantity can be changed by selecting the column
Points in correspondence with the line of the quantity, then selecting
the desired style in the drop-down list.
To display or hide the vertical cursor, select or deselect respectively the
option Vert. Cursor.
To apply the changes referred to a quantity in all the displayed graphs (in
the event the same quantity appears in several graphs), select the option Apply
to all (the option is effective only since the moment of its selection,
so select it before making the changes).
Two horizontal lines can be displayed in the graph, corresponding to threshold levels (High and Low) defined by the user. To view thresholds, select the corresponding options and enter the desired values in the fields next to the options.

To save the file with the properties set, select the command Save as....
Changing
the name of the quantities:
The names of the quantities appearing in graphs and tables can be changed
by selecting the command Change Channel name in the Tool
menu.

In the window Change Channel Description, select the quantity you want to change the name of, then enter the new name in the field Channel Description ( max. 8 characters).

Press OK to confirm.
To save the file with the new names, select the command Save as....
Markers:
Two reference points can be selected in the trend of a quantity and the
difference between two points, or the minimum, the maximum or the average of
the graph values comprised between the two selected points can be calculated.
To select the first reference point, press the button Activate
Marker M1 or select the command Marker M1 in the Tool
menu.

Click with the left key of your mouse on the first reference point, in the graph of the quantity of interest. M1 marker appears in red in the graph.

To select the second reference point, press the button Activate Marker M2 or select the command Marker M2 in the Tool menu.

Click with the left key of your mouse on the second point of the graph of interest (select two points of the same trend so as operations with markers will make sense), a window opens requesting the type of calculation to perform. Select:
- Difference M2-M1, to calculate the difference between values in the two selected reference points;
- Max M2-M1, to calculate the maximum value in the time interval within the two selected reference points;
- Min M2-M1, to calculate the minimum value in the time interval within the two selected reference points;
- Average M2-M1, to calculate the average value in the time interval within the two selected reference points;
- Total M2-M1, to calculate the sum of the values within the two selected reference points.

M2 marker and a mobile label with indicated the values in the two reference points and the calculation result appear in the graph. To place the label in a fixed position, click with the left key of your mouse on the desired position.

The time position of the two reference points M1 and M2 is also indicated in the table of the quantities values.

M1 and M2 markers can be displaced by simply clicking with the left key of your mouse in another point of the graph. When a point is selected, the marker enabled, i.e. the last positioned marker, is moved. The enabled marker is indicated by the label M1 or M2 in black color under the mouse pointer. To move the disabled marker, press first the button Activate Marker M1 or Activate Marker M2 according to the marker to be enabled.

To save the markers, press the button Save Markers or select the command Save Markers in the Tool menu. A window opens allowing the background and the label text color of the markers to be selected. Select the colors and press Save.

The command Save Markers saves the label of the markers in the file with the recorded data.
To delete the not yet saved markers in the graph, press the button Delete Markers or select the command Delete Markers in the Tool menu.

The command Delete Markers doesn't delete the already saved markers. To delete or change the already saved markers, see the section Changing the markers and the labels.
Labels:
Notes highlighting the points of interest can be entered in the graph. To
add a label containing some text, press the button Insert Label or select
the command Insert Label in the Tool menu.

Click with the left key of your mouse on the point where you want to enter the label in the graph of the quantity of interest, the window Label Setup will open.

Enter the text of the label (max 60 characters), select background and text color, type and dimension of the font, type of frame surrounding the text and rotation (orientation) of the label. The option Connected draws a vertical line that joins the label to the closest time trend. At the end, press the Save button.

To definitely save the labels in a file
of your PC, you need to select the command Save as....
Labels are saved in a file together with the recorded data; by default, the
program offers to save the labels in the same open data file.
If you close a window containing some labels that were not definitely saved
with the command Save as.., the program will ask if you want
to save the changes before closing the window.
Changing the
markers and the labels:
To change the properties of labels and markers, press the button Edit
Label or select the command Edit Label in the Tool
menu.

The window for property changes opens. Select the label you want to change the properties of, in the field Labels List (note: after saving, the markers are considered as labels, since their movement doesn't cause the update of the markers values).

The text of the selected label appears in the panel below the label list; in this panel you can change the text. Select background and text color, type and dimension of the font, type of frame surrounding the text, rotation (orientation) of the label. The option Connected draws a vertical line that joins the label to the closest time trend. At the end, press the Save Changes button.
Note: when you change the properties of a label, before pressing the button Save Changes be sure to select the graph to which the label belongs.
To delete the label, select it in the field Labels List and press Remove. To delete all labels, press Remove All.
To definitely save the changes, you need to select the command Save as....
Date/Time Format:
In data displaying, the time can be indicated in absolute manner (date and
time are displayed) or relative manner (the time in seconds is shown, that has
elapsed since the start time, considered as zero time, of the displayed time
interval). To change the time display format, select the command "Date-Time
Format" in the Display menu.

In the window Graph time format, select the Absolute or Relative format.

If the absolute format is selected, choose if to view either the date and the time, or only the date or only the time.

Press OK to confirm the settings.
Organizing
the panels:
Each panel can be closed, minimized or enlarged separately (use standard
icons in the right upper corner of the panel or select the panel and press the
right key of your mouse to access the corresponding commands). To manually resize
a panel, drag the edges with your mouse. If you close some panels, the open
panels can be redistributed by pressing the button Tile Vertically or
the button Tile Horizontally (in alternative, select the command Tile
Vertically or the command Tile Horizontally in the View menu).
A maximum of six panels can be tiled, additional panels will be overlapped.

All panels can be simultaneously closed by selecting the command Close all in the File menu.
The Instrument Monitor function displays the measurements registered by the instrument in real time on the PC's monitor, both graphically and numerically. The data input into the instrument are read and displayed according to a set update time from 1 second to 5 minutes for HD21xx, HD32.7 and HD32.8, and from 1 second to 60 minutes for HD31xx.
When the Monitor button is clicked or the menu item Instrument >> Monitor is selected the reading of the instrument's parameters is started.

The following page allows setting of the parameters.
Setting for HD21xx, HD32.7 and HD32.8
The acquisition interval can be chosen from 1 second to 5 minutes (Select Monitor Interval).

To send the measured data and/or the alarms to an email address, select the Send data by e-mail and/or the Send alarm by e-mail options.

The E-mail settings configuration window will appear: here you can see the details for their correct configuration.
If you select the Send data by e-mail option, select the interval for sending the data from 1 hour to 24 hours: upon expiry of the single time interval, the data logged in that same interval are zipped up and sent via email as attachment. In order to check the settings are correct, a 1-minute sending interval was added: this interval is only used for the check to avoid having to wait the 1-hour minimum interval. As soon as you have checked that the software is set correctly, enter any of the intervals from 1 to 24 hours.
Press OK to open the main window of the MONITOR function.
Setting for HD31xx
In the MONITOR column, select the variables to be captured.

The acquisition interval can be chosen from 1 second to 60 minutes.

To send the measured data and/or the alarms to an email address, select the Send data by e-mail and/or the Send alarm by e-mail options. The E-mail settings configuration window will appear: here you can see the details for their correct configuration.
If you select the Send data by e-mail option, select the interval for sending the data from 1 hour to 24 hours: upon expiry of the single time interval, the data logged in that same interval are zipped up and sent via email as attachment. In order to check the settings are correct, a 1-minute sending interval was added: this interval is only used for the check to avoid having to wait the 1-hour minimum interval. As soon as you have checked that the software is set correctly, enter any of the intervals from 1 to 24 hours.
Press Start to open the main window of the MONITOR function.
Main window of the MONITOR function

The Monitor main window displays the acquired measurements
in numerical format. One or more windows corresponding to the quantities measured
or calculated by the instrument will be present according to the instrument
connected. Name, measuring unit, measurement value and minimum (MIN) and maximum
(MAX) detected values are displayed for each quantity.
The graph and the table of the measurements acquired with the Monitor function
are shown in the DeltaLog9 main window.
To each measurement variable are associated two alert limits:
an upper limit (High Level) and a lower limit (Low Level).
Upon overcoming either of the two limits, one or more events can be associated.
The configuration window automatically appears when one of the two items High
Level or Low Level is selected.

The limit value must be inserted in the Level box. The alarm is generated only if the limit is exceeded by the number of seconds inserted in the Duration box.
The events associated to the alarm violation are:
1. |
Instrument start logging: upon overcoming the limit for the set time, the logging function (datalogging) is started in the instrument. |
2. |
Instrument stop logging: upon overcoming the limit for the set time, the logging function (datalogging) is stopped in the instrument. |
3. |
Computer beep: an acoustic alert signal is issued each time a new sample exceeding the limit is captured. |
4. |
Exec. software / Open File: on the first violation of the limit for the set time, the selected program is started or the selected file is opened. Use the Browse button to search the application to be started or the file to be opened. |
| 5. | Send e-mail: on the first violation of the limit for the set time, an email is sent with the message entered in the box below the option. To set the email please see this paragraph. |
If no event is selected, the violation of the limit appears only in the Alerts History.
Upon overcoming either of the limits for the set time, a red box is turned on and remains on until the Reset button is pressed.

Alerts History: the events associated to the alert limits (overcoming of the threshold and pressing of the Reset button) are recorded in a text file (txt extension). To open the file, press the Alarm List button. The text file is deleted if a new Monitor session is started.
![]() |
To end the Monitor function, press the Monitor button in the Icons Bar and press Yes when asked for confirmation. |
The data received by the instrument are shown in the main window of the application: these data must be saved by pressing the Save As... button or selecting the menu item File >> Save As...
The Monitor function captures and displays the data sent in real time by the instrument connected to the PC. The data can be sent, according to set intervals, to an email address. Before sending, the data are zipped up to reduce the telephone connection time. The compressed files can be extracted in their original format using software applications such as WinZip®, WinRAR®, ...
The data received using the Monitor function are analysed in real time and some alert limits can be associated to them: on their overcoming, one or more events can be generated. Among them there is the possibility of sending a notice via email to a predefined address.
The two above functions require the entry of some parameter for the email account used to send the message: select the menu item Option >> E-mail Settings.

The following window opens:
Connection settings
The first section concerns the Connection settings: if the computer
uses an analog modem or ADSL telephone line connection, select the modem
item and enter the User Name, Password parameters. For the
analog modem connection, select the provider's Phone Number. These
parameters appear, for example, when the Internet connection is started.
If the computer is connected through a local network (LAN) select the Network item. The User name, Password and Phone number fields will be disabled.
E-mail settings
In the second section of the E-mail settings
window enter the name of the sender, the e-mail address of the recipient and
the subject of the message.
To check the correctness of the settings, you can send a test message to your email address using the Test sending... button on the bottom left: if the settings are correct no errors are signalled and the message reaches its correct destination.
![]() |
With the instrument connected, press the Instrument Setup button or select the menu item Instrument >> Instr. Setup to open the dialog box and set the parameters. |
The window is different according to the instrument connected: one for the HD21xx models, one for the HD32.7 and HD32.8 models, and another for the HD31xx models.
The window for the HD21xx models is divided into 6 parts:

Instrument: shows information about the instrument and the connected probes.
User ID is a customizable label that can identify, for example, the name of the instrument's user and is reported on the data printouts.
Probe A (and B if there are two inputs) summarizes the characteristics of the probe connected to the instrument. This item cannot be modified.
Date - Time: if necessary, used to update the instrument’s date and time; by checking the Update instrument Date-Time to PC Date-Time” item, the instrument date and time are automatically updated with the PC date and time.
Datalogging: Log Interval represents the interval between two subsequent recordings (sampling interval) and can be set from 1 second to 1 hour.
Power-off during datalogging: by setting a sampling time equal or higher than 1 minute, it is possible to enable the instrument's automatic turning off between two subsequent acquisitions.
Instrument: Instrument Auto Power-off: it enables the instrument's automatic turning off after 8 minutes.
Battery level displays the battery voltage: a green LED near it indicates that the battery charge is sufficient, a red LED that it must be replaced. The battery charge indication is replaced by the External message when the external power supply is connected.
Channels: it modifies the variable associated to each channel and the relevant unit of measurement. For some instruments the variable is unique and therefore cannot be modified.
Enable relative values enables relative measurements.
Memory: represents the % of memory available for the logging operation. According to the setting of the Log Interval parameter, the available time before the instrument memory will get full is provided.
Confirm the settings with the Apply button or press Cancel.
The window for HD32.7 and HD32.8 models is divided into 6 parts:

Instrument: shows information about the instrument and the connected probes.
User ID is a customizable label that can identify, for example, the
user's name and it is reported on the data printouts.
Date - Time: if necessary, it is used to update the instrument date and time; by ticking the Update instrument to PC Date-Time item, the instrument date and time are automatically updated with the PC date and time.
Datalogging: the Log Interval
represents the interval between two subsequent recordings (sampling interval)
and it can be set at 2 seconds to 1 hour.
The Circular Memory manages the datalogging mode: if yout tick it,
when the memory is full, older data are overwritten by newer data. If you don't
tick it, when the memory is full, datalogging stops (for further details, see
the instrument manual).
Power-off during datalogging: by setting a sampling time equal or higher
than 1 minute, the instrument automatic turning off can be enabled between two
subsequent acquisitions.
Instrument: Instrument Auto Power-off: it enables the instrument automatic turning off after 8 minutes.
Battery level displays the battery charge: a green LED indicates that the battery charge is sufficient, a red LED means that it must be replaced. The battery charge indication is replaced by the External message when the external power supply is connected.
Probes: it shows the list of probes connected
to the instrument with the following items: type, serial number and calibration
date.
Unit of Measurement allows selecting the unit of measurement among
°C, °F and °K.
Memory: it shows the list of 64 sections in the instrument memory. It indicates if the memory is empty or, if it has been used, it shows the date and time of the first sample.
Confirm the settings with the Apply button or press Cancel.
The window for the HD31xx models is divided into the following parts:

Instrument: shows information about the instrument and
the connected probes.
ID is a customizable label that can identify, for example, the user's
name.
Probe Info: it shows the list of probes connected
to the instrument with the following items: type, serial number and calibration
type.
Cal. Type allows selecting the calibration type among:
• Auto: the user calibration is used, if available, only if it has been carried out with the same instrument to which the probe is connected. If the user calibration is not available, the factory calibration is used.
• Factory: the factory calibration is used, even if a user calibration is available.
• User: the user calibration is used, if available, even if it has been carried out with an instrument different from that to which the probe is connected. If the user calibration is not available, the factory calibration is used.
Date - Time: if necessary, it is used to update the instrument date and time; by ticking the Synchronize Instrument Date-Time check-box, the instrument date and time are automatically updated with the PC date and time.
Log. Parameters:
the Log Interval represents the interval between two subsequent recordings
(sampling interval) and it can be set from 1 second to 1 hour.
Start Log indicates how logging starts: if you select Manual,
logging has to be started through the "LOG>>RUN" command of
the instrument. If you select At time, Start Date (delayed start)
and Stop Date (delayed stop) boxes become active. Here you can enter
date and time to start and stop logging. Anyway, in both cases logging can be
started and stopped either from PC or from instrument.
Log Auto Off: by setting a log interval equal or higher than 1 minute,
the instrument automatic turning off can be enabled between two subsequent acquisitions.
Channel configuration: sets the quantities to
be displayed on the instrument LCD.
CH: number of the LCD row.
Probe: select the input of the instrument (A, B or C). Select OFF
to indicate no input.
Meas.: select the quantity to be displayed.
Unit: select the unit of measurement of the quantity.
Meas. Type: select the type of measurement among instantaneous (Inst.),
minimum (Min.), average (Avg.) and maximum (Max.).
Stat.: select the status of the RECORD function (for the calculation
of minimum, average and maximum): Disable, Auto or Manual.
Relative: select the check-box to display the relative measurement.
Log.: select the check-box to select the quantity for logging.
Automatic serial output: select the check-box to periodically send the
measure to the USB output.
User: sets the protection status of the calibration: Locked = protected mode, Unlocked = unprotected mode. To change the status, the password must be entered. To change the password, press Modify User Password (available in unprotected mode only) and enter the new password.
PDF Settings:
enter the info to be written in the PDF report generated by the instrument at
the end of a logging.
Password: it is the password for the PDF report (different from the password
to protect calibration), used to detect any alteration of report data.
Battery: displays the battery charge level.
Plot Channel: selection of the measure to display graphically.
Auto USB Output of data: represents the sending interval of the selected measurements to the USB output; can be set from 1 second to 1 hour.
Confirm the setup with the Apply button or press Cancel to end the operation.
The Check PDF file signature function of the File menu is used to detect any alteration of data in the PDF report generated by the instrument HD31xx at the end of a recording.

Select the PDF file to be checked and enter the check password.

Press the Check signature button: a message indicating the result of the check will appear.
The upper part of the DeltaLog9 page contains the main menu from which all functions offered by the application can be accessed.
All that is necessary to activate a function is the opening of the drop-down menu where the function is located and its selection with the mouse.
Open
Opens a saved file. The files managed by the application have dl9, dr9, d31,
d31m and d32 extension.
dl9, d31 and d32 are data files obtained from a logging operation while
dr9 and d31m are files recorded in real-time using the Monitor function.
For the proper operation of the Open command, make sure the connection
between DeltaLog9 and data logger is not enabled (in case connection is enabled,
press Disconnect).
Save As…
Saves the open data file.
For the models HD21xx, HD32.7 and HD32.8, the window listing the data reports
opens: each report represents a measurement session. It is possible to select
them all or only some of the pages to be saved: to select a consecutive group
of reports, click on the first one and then, holding down the Shift
button, click on the last one. To select a non consecutive group of pages, click
on each one while holding the Ctrl button down. To enter the name and
position of the file use the Browse button. The File Name
field shows the name and the position of the file. The OK button is not
activated until at least one report has been selected.

Export to Excel
Exports the currently active data to CSV format, for data display with Microsoft
Excel program. Up to 30000 samples per time are exported: for higher
quantities you are prompted for the data block to be exported.
Export to Word
Exports the currently active data, to DOC format,
for data display with Microsoft Word program.
Export to PDF
Exports the currently active data into PDF format. The data are exported in
tabuar or graph form according to the selection done. To enter a text also in
the footer, select the option Print footer and enter the text in the
field below the option.

Check PDF file signature
Checks that the PDF report generated by the instrument HD31xx has not been altered.
Export as formatted text
Exports the currently active data into a text file with the separation character
";".
Close
Closes an open file.
Close All
Closes all the open files.
Print
Prints the current file. The data displayed in the main page (data table or
graph according to the selection done) are printed. In the tabular printout,
also the maximum, minimum, and average values, and the instrument parameters
are printed. In the graph printout, also the instrument parameters, the notes
and any possible labels or markers entered by the user are printed. To enter
a text also in the footer, select the option Print footer and enter the
text in the field below the option.

Printer Setup
Opens the dialog box in which the printer options can be set.
Exit
Closes the application.
Connect
Connects the DeltaLog9 application to the instrument: if the Autodetect
function in Option >> Port Settings is enabled, the communication
port parameters are set automatically.
Disconnect
Disconnects the DeltaLog9 application from the instrument.
Inst. Info
Opens a window with the information of the instrument.
Monitor
Starts the function that displays the measurements registered by the instrument
in real time on the PC's monitor (See the details).
Instr. Setup
Opens the configuration page of the instrument connected to the PC (See
the details).
Start Recording
Starts the logging of the data on the instrument using the current settings.
To modify and display the recording parameters, start the Setup (See
the details).
Stop Recording
Ends the logging of the data (See the details).
Download data
Transfers the data recorded by the instrument during the measurement operations to the PC. During this phase a window is displayed showing the progress of the download and the number of records saved. The download operation can also be interrupted. (See the details)
Clear Instr. Mem.
Clears all the files contained in the instrument's memory. Caution:
the cleared files cannot be recovered.
For the models HD21xx, HD32.7 and HD32.8, the command clears all the data contained
in the instrument's memory.
For the models HD31xx, wait for the instrument to go into MSD (Mass Storage
Device) mode, that is necessary for the program to read the files stored in
the SD card of the data logger, then select the files you want to be deleted.
To select all the files, press the Sel. All button. To delete the data
in CSV and/or PDF format as well, select the corresponding options. Press the
Delete button to delete the selected files. The deletion progress is
highlighted by the bar in the lower part of the window.

Note: when the deletion window is closed, the HD31xx data logger returns from MSD mode to normal operation mode (HID); if the program doesn't succeed in returning the data logger to HID mode, simply disconnect and reconnect the CP31 USB cable.
Set Zero
This command is available only for the instruments that use differential
pressure probes and is used to set the offset to zero. Set up the probe for
resetting (please see the details in the respective user manuals), then select
the command and, when ready, press Yes when asked for confirmation.
Integration
This command is available only for the instruments that use photometric/radiometric
probes.
View Graph
Displays open file data in graph form.
View Table
Displays open file data in table form.
View Graph and Table
Displays open file data in table and graph form.
Tile Vertically
Tiles vertically all data display panels.
Tile Horizontaly
Tiles horizontally all data display panels.
Date-Time format
Changes the time display format in graph abscissas.
Meas. Settings
Displays a window showing model, serial number, firmware version and user
code of the instrument, and info about the connected probes.
Statistics
It displays a window that shows, for the current report, the number of samples,
the average value of each variable, the maximum and minimum value.

Instrument Bar
It enables or disables the Instrument Bar.
Status Bar
It enables or disables the Status Bar.
Copy to Clipboard
This command copies the current window to the Windows Clipboard and allows it
to be pasted in another application: the graph is pasted as a bitmap image,
the data table as a formatted list with the TAB separator symbol.
If both the table and the graph are displayed, a window opens allowing to select
the data to be pasted: Table or Graph.

Confirm with OK. Open the destination application (editor, spreadsheet, graphic application, ...) and use the Paste command (or Paste Special if available) to paste the clipboard's content.
Change channel name
Changes the name of the displayed quantities.
Zoom +
Enlarges a selected area of the graph. (See the details)
Zoom -
Returns to the previous zoom level.
Zoom Settings
Opens the window for the zoom manual setting.
Move Graph
Moves the selected graph with the mouse.
Graph Properties
Opens the panel for setting graph properties.
Insert Label
Adds a label on the selected graph.
Edit Label
Opens the window for changing labels and markers properties.
Marker M1
Adds marker number 1 to the selected graph.
Marker M2
Adds marker number 2 to the selected graph.
Save Markers
Saves the markers added to graphs into the data file.
Delete Markers
Deletes not yet definitely saved markers in the graph.
Port settings
Opens the dialog box for setting the connection of the instrument to the software.
The function is only enabled when there is no instrument connected.
E-mail settings
Opens the window to set the parameters to send the email messages. (See
the details).
Software Upgrade
Updates DeltaLog9 software.
Firmware Upgrade
Updates the firmware of the instrument.
DeltaLog9 Info
Information on the software version.
DeltaLog9 Licence
Software license with the final user.
DeltaLog9 Handbook
DeltaLog9 software manual.
DeltaLog9 Language
Selection of DeltaLog9 software language. Close and
reopen the program to enable the new language.
To speed up the use of the system, some operations accessible trough the menus are also located on the command bar immediately beneath the main menu in the form of buttons.
|
|
Open |
|
|
Save as… |
|
|
Connect Connects DeltaLog9 program to the instrument. |
|
|
Disconnect |
|
|
Monitor |
|
|
Download data |
![]() |
Instrument setup |
|
|
Start Recording
|
|
|
Stop Recording |
|
|
View Graph |
![]() |
View Table Displays the current data in table form. |
![]() |
View
Graph and Table |
|
|
Meas. Settings |
|
|
Zoom + |
|
|
Zoom - |
|
|
Move Graph |
![]() |
Insert Label Adds a label to the selected graph. |
![]() |
Edit Label Opens a window for changing the properties of labels and markers. |
![]() |
Marker M1 Adds marker number 1 to the selected graph. |
![]() |
Marker M2 Adds marker number 2 to the selected graph. |
![]() |
Save Markers Saves the markers added to graphs into the data file. |
![]() |
Delete Markers Deletes the markers that have not been yet definitely saved from the graph. |
![]() |
Graph Properties Opens the panel for setting graph properties. |
![]() |
Copy to Clipboard Copies the current graph or table to the Windows Clipboard. |
![]() |
Export to Excel Exports the current data to CSV format for data display with Microsoft Excel program. |
![]() |
Export to Word
Exports the current data to DOC format for data display with Microsoft Word program. |
![]() |
Export to PDF Exports the current data to PDF format. |
| Statistics Calculates the statistic parameters on the selected report (number of samples, average, minimum, and maximum). (See the details) |
|
![]() |
Tile Vertically Tiles vertically all data display panels. |
![]() |
Tile Horizontaly Tiles horizontally all data display panels. |
![]() |
Print Prints the current data as displayed (table or graph). |
Serial/USB port connection status
Symbol indicating the connection status and parameters between DeltaLog9 and the serial/USB port.
Depending on the connection status the symbol can display the following values:
|
|
DeltaLog9 disconnected. |
|
|
DeltaLog9 disconnected because an error occurred during the attempted connection (see the paragraph Trouble shooting). |
|
|
DeltaLog9 correctly connected with relevant parameters. |
The program operating the instrument (firmware) can be updated through the
Firmware Upgrade function in the Option menu.
The first versions of HD21xx instruments can be updated by the manufacturing
house only: to check if your instrument can be directly updated through DeltaLog9,
please see the chart below.
In the chart you will find the first version of the firmware for each model
that can be updated directly by the user through DeltaLog9 software.
MODEL |
|
VERSION |
DATE |
|
|
|
|
HD2101 |
|
1.07 |
01/09/2006 |
HD2102 |
|
1.09 |
01/09/2006 |
HD2103 |
|
1.09 |
01/09/2006 |
HD2105 |
|
1.06 |
01/09/2006 |
HD2106 |
|
1.06 |
05/09/2006 |
HD2107 |
|
1.05 |
05/09/2006 |
HD2108 |
|
1.05 |
01/09/2006 |
HD2109 |
|
2.03 |
31/08/2006 |
HD2114 |
|
1.04 |
26/09/2006 |
HD2114B |
|
1.04 |
26/09/2006 |
HD2114P |
|
1.03 |
01/09/2006 |
HD2124 |
|
1.04 |
01/09/2006 |
HD2127 |
|
1.04 |
01/09/2006 |
HD2128 |
|
1.04 |
05/09/2006 |
HD2134 |
|
1.04 |
26/09/2006 |
HD2134P |
|
1.03 |
01/09/2006 |
HD2156 |
|
1.07 |
05/09/2006 |
HD2164 |
|
1.04 |
26/09/2006 |
HD2178 |
|
1.03 |
04/09/2006 |
|
|
|
|
HD32.7 |
1.10 | 15/06/2007 |
|
| HD32.8.8 | 1.10 | 27/06/2007 |
|
| HD32.8.16 | 1.10 | 27/06/2007 |
To know your current firmware version, please connect the instrument to DeltaLog9 and enter Setup. The firmware version is displayed in the upper part among instrument parameters:
If your firmware version is the same or subsequent to the one in the chart above, the update can be carried out through DeltaLog9. Previous versions can be updated by the manufacturing house only.
To check the availability of firmware updates, please visit "www.deltaohm.com" web site under section Support >> Firmware.
Procedure:
1) Connect your instrument to the computer in which DeltaLog9 program is installed, by using the appropriate cable.
2) Turn the instrument on and connect it by pressing Connect button.
3) In the Option menu select Firmware Upgrade.

4) You will see a window asking you to confirm the update: press Yes to continue. To exit without making any changes, press No.
5) The "Firmware Loader" program, which runs the whole update, will start.


6) Press Browse... to select the update file having a HEX (HD21xx, HD32.7 and HD32.8) or DFU (HD31xx) extension, which you have already copied in a folder.


7) To begin writing the file, press the Start (HD21xx, HD32.7 and HD32.8) or Start Upgrade (HD31xx) button. The program will continue with update automatically.


Note: in some models the instrument display may turn off while updating;
in that case, the instrument will turn on automatically once the update is finished.
Note: when the "Firmware Loader" program starts, the model HD31xx waits for the new firmware for two minutes. If the upload of the update file is not started within two minutes, the instrument switches off; in this case, press the ON/OFF button to switch the instrument on again.
8) Once the update is finished, the message "Uploading executed correctly" (HD21xx, HD32.7 and HD32.8) or "Upgrading successfull" (HD31xx) will appear. The update is complete. If necessary, close the window of the "Firmware Loader" program.
The function checks if there are any DeltaLog9 software upgrades available. If so, it will continue with download and installation. An Internet connection is necessary.
In the Option menu select Software Upgrade.

Select the language and press OK.

The program checks if there are any upgrades available and, if so, it asks you if you want to download it: press Yes to download it.
The upgrade file will be downloaded and, once the transfer is complete, a window will appear asking if you want to install the new version: press Yes to proceed with the installation. Once the upgrade is finished, the program closes and it will reopen in the new version.
Failed connection problems
If the application does not connect, check the following:
If a serial connection is used, check that there are no active applications using the serial ports (e.g. Hyperterminal) on your computer. In such case close these applications and retry.
Do not use extensions for the serial cable.
If there are devices connected to other serial ports (e.g. a modem), they could be interfering with the DeltaLog9 application. In this case it is better to set the parameters of the serial port manually by deselecting the Auto detect option in the connection settings.
To minimize data transfer times, it is recommended that the maximum baud rate is set.
USB connection problems
DeltaLog9 installation package contains a guide for USB drivers installation and removal (the USB drivers installation is not necessary for the HID connection).