HD52.3D-S software manual
Introduction

HD52.3D-S program allows the management of HD51.3D.... and HD52.3D.... series ultrasound anemometers from your computer.

With this software you can:

• configure the instrument;

• display measurements in real time (Monitor), in graph form as well;

• save in your computer the data acquired thanks to the Monitor function;

• Manage graphical presentation, printing and export of the data acquired with the Monitor function in Excel format.

The software is equipped with an automatic search function for the devices connected to your computer.

 


Software startup and connection

Connect the instrument to your computer. The instrument can be connected in the ways illustrated hereunder:

• direct connection of the instrument RS232 port to a PC RS232 port;

• connection of the instrument RS232 port to a PC USB port by means of the RS52 cable (supplied with built-in USB/RS232 converter);

• connection of the instrument RS485 port to a PC RS232 or USB port by means of a RS485/RS232 or RS485/USB converter (for HD52.3D... only if the instrument is set in configuration mode with RS485 interface, the connection is not possible if the instrument is set in one of the operation modes; for HD51.3D..., the auxiliary RS485 port can be used, which is always in configuration mode); only one instrument can be connected, because the software does not manage the addresses;

• connection of the instrument RS422 port to a PC RS232 or USB port by means of a RS422/RS232 or RS422/USB converter (only if the instrument is set in configuration mode with RS422 interface, the connection is not possible if the instrument is set in one of the operation modes).

See the instrument user manual for details on connections.

If a USB connection is used, you need to install in your computer the drivers of the RS52 or RS51K adapter included in the HD52.3D-S software package: see detailed instructions in " A guide to the installation of USB drivers " in the " Documentation " section of the software package.

Start the program by double-clicking on the program icon on the desktop or by selecting the HD52.3D-S item in the Senseca folder in the Startup menu.

If you are connected to the internet, the program will firstly check if a software update is available and, if so, it will ask if you wish to install the update. If the program doesn't detect any connection to the internet or if no updates are available, the message will not be displayed and the program main window will appear.

Select the Serial Connection item from the Tools menu.

Select the number of the COM port of the computer the instrument is connected to, then press Apply to return to the main window. If the port number is unknown, don't change the setting and press Apply to exit; the program will automatically search for an instrument connected to the available ports on the computer, starting from the one that has been set. The remaining communication parameters cannot be changed.

Power the instrument, then select the Connect icon on the command bar, or the Connect item in the Tools menu.

WARNING: with RS232 (or USB by means of the RS52 or RS51K cable) connection, if the instrument is not set in configuration mode, but in one of the operating modes, you should reboot the instrument to perform the connection, then press the Connect key within 10 seconds from reboot.

WARNING: with RS485 (main port for HD51.3D...) or RS422 connection, the instrument must be already set in configuration mode with RS485 or RS422 interface and the connection is possible after 10 seconds from power on. Using the auxiliary RS485 port in HD51.3D ..., the connection is always possible.

A correct connection is highlighted by a green label on the left of the status bar. Additionally, the status bar shows in the order: instrument model, analog output type, user code, serial number and firmware version.

If connection fails, an error message will be displayed; in this case, check the correctness of connections and settings of the serial connection.

At the end of a connection and before disconnecting the cables, select the Disconnect icon in the command bar, or the Disconnect item in the Tools menu.

 


Main window

The following areas can be found on the screen:

1. Menu: contains the menu items.

2. Command Bar: includes the icons representing the program main commands.

3. Folders window: displays all the computer folders and the default working folder.

4. Files window: all the files contained in the selected folder in the folders window (point 3).

5. Properties window: shows the features of the file selected in the files window (point 4).

6. Status Bar: supplies info on the serial connection and on the connected device.

7. Measurements window: displays in real time the measurements detected by the instrument (the fields referring to quantities not measured by the instrument are disabled) and the status of the heating (if present). The arrow on the wind rose indicates the current wind direction.

The various areas can be reduced by dragging the borders that separate the different panels with your mouse.

The measurements window (point 7) can be enlarged to full screen by selecting the "Zoom" icon on top right of the window.

To resize the window to its original dimension, select again the icon.

 

WIND STATISTICAL VALUES

The measurements window displays the minimum, the maximum and the average (AVG) of wind speed (WS) and direction (WD) measurements.

If the INS (instantaneous) option is selected, the minimum and maximum values are calculated starting from the reset of the statistics, while the average values tend to the current measured values.

If the AVG2 or AVG10 option is selected, the statistical values are calculated in 2 or 10 minutes intervals respectively (on the wind rose, the orange sectors indicate the values used for AVG2 calculation, while the green sectors indicate the values used for AVG10 calculation).

To reset the statistics, select the Instrument Settings icon in the command bar, then the Advanced setup section and the RESET button.

 

ALTIMETRIC PARAMETERS

The measurements window displays the QFE and QNH parameters, used in aviation to determine the altitude of the aircrafts.

QFE is the value of the atmospheric pressure at ground level (for example, the runway of an airport), calculated as a function of the atmospheric pressure measured by the weather station and the height of the pressure sensor above ground. Entering the QFE value in an altimeter, this will indicate zero when the aircraft is on the airport runway.

QNH is the value of the atmospheric pressure at mean sea level, calculated as a function of the QFE parameter and the elevation of the place where the weather station is located. Entering the QNH value in an altimeter, this will indicate the airport elevation when the aircraft is on the runway.

To set the values needed to calculate the QFE and QNH parameters, select the Instrument Settings icon in the command bar, then the Advanced setup section.

 

TILT ANGLES AND COMPASS MEASUREMENTS IN HD51.3D...

To view the Tilt angles and compass measurements in HD51.3D... models equipped with the optional sensor, select the Tilt (°) icon in the command bar.

 


Default working folder

All files processed by the software are saved in a folder named "Predefined folder". During installation, the software creates the default working folder Senseca\HD52.3D-S in the installation disk root. The folder, in turn, contains the "Monitor" sub-folder that includes the data acquired with the Monitor function.

To change name and position of the working folder, press the Predefined Folder command in the Tools menu.

The following window will appear:

Press the Change... key and select the new folder, then confirm by pressing OK.

Press the Apply key to close the window. Reboot the program to make the change effective.

 


Configuration of the instrument

To configure the instrument, select the Instrument Settings icon in the command bar.

The Anemometer Setup window will appear.

The window is divided into several sections, listed on the left of the window, that allow to perform the following settings:

General settings: user code, heater and magnetic compass enable/disable, wind speed minimum threshold, calculation mode for mean values of wind speed and direction.

Setting of measurement units: for wind speed, temperature and barometric pressure quantities.

Setting of analog outputs: association of measured quantities to analog outputs.

Setting of operation mode: selection of one of available operating protocols.

Setting of configuration mode: selection of the connection interface in configuration mode.

Settings for RS232 and RS485 proprietary modes

Settings for NMEA mode

Settings for MODBUS-RTU mode

Settings for SDI-12 mode

Advanced settings: reset of wind speed and direction statistics, settings for QFE and QNH parameters.

 

General settings

At startup, the Anemometer Setup window displays the General settings window:

This section allows configuration of the following parameters:

User code : alphanumeric code identifying the instrument. Maximum length 34 characters.

Heating : for the models equipped with a heating system, select Enable heating to activate the heating function of sensors. To disable heating, select Disable heating.

Enabling magnetic compass : select Enabled to activate the compass compensation of the wind speed and direction measurements. To disable the compass, select Disabled. The command is available from version 2.06 of the instrument firmware.

Wind speed threshold (m/s) : if the wind speed is very low, the determination of the direction can result incorrect. A speed threshold value can be set below which the direction value is frozen on the last detected value.

Time interval for the calculation of average speed and average direction (seconds) : the wind average speed and the average direction are calculated with reference to the set time interval.

Method for the calculation  of average wind speed and direction : selecting vector averaging, the average of the values along U-axis and V-axis is calculated. The average intensity and the average direction are those determined by the average of the two coordinates. Selecting scalar averaging, the average intensity is calculated as the average of intensities without considering the direction. The average direction is calculated as the average of directions and expressed according to the extended characteristic. See the instrument user manual for details on extended (wrap-around) characteristic.

 

Setting of measurement units

Select the Measuring Units section to set the measurement unit for wind speed, temperature and barometric pressure.

The following measurement units can be set:

Wind speed measuring unit : optional selection among m/scm/skm/hknot and mph.

Temperature measuring unit : optional selection between °C and °F.

Atmospheric pressure measuring unit : optional selection among  hPammHginchHg mmH20, inchH20 and atm.

For each measurement unit, you can set the resolution with which the corresponding quantity is displayed in the measurements window of the software.

Note: the measurements resolution setting is saved in the PC, not in the instrument; therefore, if the PC is changed, the resolution must be set again (if different from the default one).

 

Setting the analog outputs

Select Analog outputs AN1 AN2 section to configure the analog outputs.

The following parameters can be set:

Association of the analog outputs : select one of the three available options.

By selecting the wind speed along the axis of the arrow and wind direction referred to the axis of the arrow option (Tunnel mode), the wind direction measurement is not compensated by the magnetic compass, but the measurement is referred to the direction indicated by the arrow on the instrument case. The output 2 is set to full scale value if the wind blows in the direction of the arrow, and to initial scale value if the wind blows in the opposite direction. The initial scale of output 1 is associated to the speed value opposite to that associated to the output full scale.

By selecting the U and V components, the speed value associated to the initial scale of the two analog outputs is equal to the opposite of the speed value associated to the full scale of the outputs. For example, if the speed full scale value is set to 60 m/s, the speed range associated to the analog outputs is -60…+60 m/s.

Set offset and direction of the analog outputs AN1 AN2 : select if you want to add an offset to the output (for ex. go from  0...1 V to 0,2...1 V), take off the output offset (for ex. go from 4...20 mA to 0...20 mA) or invert the output direction (the analog output decreases when the associated quantity increases). The options that appear depend on the type of analog output present.

Full scale of wind speed analog output : select the value of the wind speed you want to match with the maximum scale value of the analog output.

 

Setting the operation mode

Select the Operation Mode section to set the communication protocol.

The available standard protocols are NMEA, MODBUS-RTU and SDI-12. In addition, RS232 and RS485 proprietary communication modes are available. See the instrument user manual for info on the various protocols.

The Configuration mode is the mode needed for connection to HD52.3D-S software. The Configuration mode with RS232 interface is always activated for 10 seconds at each reboot of the instrument. If the Configuration mode is already set in the instrument, you don't need to reboot the instrument to allow connection of the software.

ATTENTION : the selected mode will become active at next reboot of the instrument.

 

Setting the configuration mode

Select the Configuration section to set the connection interface in configuration mode.

 

The possible options are RS232, RS485 and RS422.

The Configuration mode with RS232 interface is always activated for 10 seconds at each reboot of the instrument. The Configuration mode with RS485 or RS422 interface, if selected, is activated after 10 seconds from reboot.

 

Settings for RS232 and RS485 proprietary modes

RS232 and RS485 section allows configuration of the operating parameters of Proprietary RS232 and Proprietary RS485 operation modes.

The following parameters can be set:

RS485 Address : setting of the instrument address for Proprietary RS485 mode. The address is an alphanumeric character ranging from  0...9, a...z, A...Z.

RS485 Baud Rate : setting of the Baud Rate for Proprietary  RS485 mode. The maximum Baud Rate is 115200.

RS232 Baud rate : setting of the Baud Rate for Proprietary RS232 mode. The maximum  Baud Rate is 57600.

RS232 string sending interval (seconds) : setting of time interval between the transmission of two consecutive strings containing the values measured in RS232 Proprietary mode.

Measurements order in the string sent in RS232 RS485 modes : the display order for the measured values in the string transmitted by the instrument can be selected at will. The transmission of any error conditions can be also requested by selecting the Errors item.

See the instrument user manual for more info on error conditions.

 

Settings for NMEA mode

Select NMEA section for the configuration of NMEA protocol communication parameters.

The following parameters can be set::

NMEA Baud rate : sets the Baud Rate for NMEA mode.

NMEA interface: selects the serial connection type between RS232, RS485 and RS422.

NMEA parity and stop bits: sets parity and number of stop bits for NMEA protocol.

NMEA string sending interval (seconds) : sets the time interval between the transmission of two consecutive strings containing  the values measured in NMEA mode. Can be set from 1 to 255 seconds.

 

Settings for MODBUS-RTU mode

Select MODBUS-RTU section for the configuration of the communication parameters of MODBUS-RTU  protocol.

The following parameters can be set:

MODBUS address : sets the instrument address for MODBUS-RTU mode. The address should range within 1 and 247.

MODBUS baud rate : sets the Baud Rate for MODBUS-RTU mode.

MODBUS interface : selects the type of serial connection between RS232, RS485 and RS422.

MODBUS parity and stop bits : sets parity and number of stop bits for MODBUS-RTU protocol.

Waiting time after MODBUS transmission : selects the waiting time between Wait 3.5 characters (option that respects the MODBUS-RTU protocol) and  Immediate Reception (option that violates the MODBUS-RTU protocol).

 

Settings for SDI-12 mode

Select the SDI-12 section to set the instrument address for SDI-12 mode.

The address is an alphanumeric character ranging between 0...9, a...z, A...Z.

 

Advanced settings

Select the Advanced setup section to set the values needed to calculate the QFE and QNH parameters, and to reset the wind speed and direction statistics.

The following parameters can be set:

Airport elevation : enter the elevation (altitude above mean sea level) of the airport (at ground or runway level, not at the level of the weather station with the pressure sensor).

Airport elevation above pressure sensor : enter the height of the weather station with the pressure sensor above ground or runway level.

Example : if the airport runway is at 82 m a.s.l. and the pressure sensor is 10 m above the runway, enter 82 in the first field and 10 in the second field.

Note: the values needed to calculate the QFE and QNH parameters are saved only in the PC and not in the instrument.

To reset the wind speed and direction statistics, press the RESET button.

 

Transferring the configuration to the instrument

The modified configuration parameters are highlighted by a green circle at the right of the parameter.

Select the Send key to store the new settings in the instrument.

After transmission of the new settings to the instrument, the green circles next to parameters disappear.

 

Reading of the instrument current configuration

When opening the Anemometer Setup window, the displayed values are those set in the instrument. Select the Read key if you wish to read again the set values, for example to check that the configuration transmission operation was successful.

 

Saving settings in your computer

Select the Save key to save the values of the set parameters in a configuration file (in txt format) in your computer.

The values of all the sections of the Anemometer Setup window are saved in a single file.

 

Opening of an existing configuration file.

Select the Open key to upload the values regarding a previously saved configuration in the Anemometer Setup window.

Then select the desired configuration file and press Open.

 

Default configuration

After changing the instrument configuration, you can return to the default configuration at any time by selecting the "Default.txt" configuration file included in the program installation folder, and transferring the configuration by means of the Send key.

 

Closing the configuration window

Select the Exit key to close the Anemometer Setup window.

If changes were made and were not transmitted to the instrument, a message will be displayed asking if you wish to transmit the performed changes before exiting.

 


Monitor

During connection, the instant values measured by the instrument are displayed in real time in the program main window. If you wish to save the measured values, the Monitor function should be used.

 

Monitor function configuration

Before starting the Monitor function, set operation by selecting the Monitor icon in the command bar, then the Monitor Setup item (in alternative, select the Monitor Setupitem in the File menu).

The following window will appear:

The saving options for the measured values can be set on the left of the window. On the right of the window, the ordinate scale of the graphs displayed during Monitor operation can be configured.

 

Saving options for measured values

1. Select the Storing frequency  of measurement values.

The storing frequency specifies how often the measurement value is saved in the file generated by the Monitor function. The settable values are: 1 s, 2 s, 5 s, 15 s, 30 s, 1 min, 2 min, 5 min, 15min, 30 min, 60 min.

If the storing frequency is equal to 1 second, the stored values coincide with the measured instant values.

If the storing frequency exceeds 1 second, the stored values are the average of the instant values measured once per second during the storage interval. For example, if the storing frequency is 1 minute, the measurement is stored once per minute, and the stored value is the average of the 60 values acquired once per second in the minute preceding the storage time.  

2. Select the File saving frequency  (closure) of the measurements file.

The measurements file is updated and saved in the computer at each storage interval. The File saving frequency field specifies how often the Monitor function closes the file where measurements are being saved and starts saving measurements in a new file. The settable values are: 1 h, 2 h, 4 h, 8 h, 12 h, 24 h.

The different saved files include only the measurements detected during the related saving interval.

The option is useful, for example, if various measurements are acquired and you wish to distribute them in several files; or if you wish to isolate the measurements detected in some hours of the day in a separate file.

3. Set the Saving start time of the measurements files.

Measurements will start to be saved in the computer at a specified time. Set the time in the H field and the minutes in the M field.

If the set Saving start time is prior to the computer current time, measurements will start immediately to be saved at the Monitor function startup.

 

Setting the graphs ordinate scale

1. Select the quantity for the setting of its graph scale.

2. Select the Automatic or Manual optionof the scale. Selecting the Automatic option, minimum and maximum scale values are automatically determined by the software with respect to measured values. Selecting the Manual option, the user can set minimum and maximum scale values optionally.

3. If the Manual option was selected, set the minimum and maximum scale values of the graph in the Lower limit and Upper limit fields respectively.

4. Repeat the setting operations for all the quantities that need a graph scale setting.

 

How to save settings

At the end of the setting operation, select Apply to save the new settings.

Or select Exit to exit without saving the performed changes.

 

Starting the Monitor function

The Monitor function can be started as follows:

• Directly in the Monitor setup window, selecting the Monitor icon at the bottom of the window.

Selecting the Monitor icon in the command bar, then the Start monitor item.

Selecting the Start monitor item of the File menu.

The Monitor window is displayed, containing in its turn several windows corresponding to the quantities measured or calculated by the instrument. Name, measuring unit, measurement value and minimum ( MIN ) and maximum ( MAX ) detected values are displayed for each quantity.

The displayed measurement values are the average of the instant measurements acquired during the set storage interval. Values are always updated once per second, even if the storage frequency is higher. For example, if the storage frequency is 1 minute, the average of the 60 values acquired once per second in the last minute is displayed. If the storage frequency is 1 second, the displayed values correspond to the acquired instant measurements.

The displayed MIN and MAX values are the minimum and maximum values detected during the preset storage interval, that is the interval used for the calculation of the displayed average measurement.

Selecting the second icon on top left, you can choose if to arrange the quantities in cascade, or else to align them vertically or horizontally.   

You can reduce the window size singularly or all windows at the same time by selecting the Minimize All item.

Selecting (checkmark ticked) or deselecting (checkmark not ticked) View Graphs and View Data items, both the current average measurement in numeric form and the trend in graph form of the last 900 values can be displayed, or else you can display only the current average measurement in numeric form or only the graph of the last 900 values.

Trends are represented starting from "0" point and move to the left on the computer screen. The graph horizontal axis shows the number of measurements.

Selecting the Beep item, a sound signal is emitted (if audio function on the computer is enabled) each time that values on the screen are updated following an acquisition.

Pointing the mouse cursor on a point of the graph, the acquisition time and the trend value on that point are displayed.

Clicking with the right key of your mouse, the following list of commands is displayed:

Copy: copies the graph in the "Notes"

Save Image As...: saves the graph as a "bitmap" image in emfpnggifjpgtif or bmp format.

Page Setup...: allows to set the page format for the graph print.

Print: prints the graph.

Show Point Values: enables or disables display of acquired values when pointing the mouse on a point of the graph.

Un-Zoom: cancels a previous zoom.

Undo All Zoom/Pan: cancels all zooms.

Set Scale to Default: adapts the vertical scale to measured values, that is applies the zoom maximum level that allows the complete display of the trend.

Note: Un-Zoom and Undo All Zoom/Pan commands are enabled only following the Set Scale to Default command.

Select the first icon on top left to exit the Monitor function:

Before exiting, you will be asked to confirm you want to exit from the Monitor function. By answering yes, values are saved in a d32-extension file into the Monitor folder included in the default working folder. The file is identified by the user code of the instrument and the starting date/time of the Monitor function.

 


Display and export saved data

data acquired with the Monitor function and saved in the computer can be recalled to be directly analyzed with the HD52.3D-S software, or else exported in Excel format.

To recall the data saved in your computer, select the Monitor folder. Then select the file containing the data to be displayed from the files list.

The property panel of the selected file shows info concerning the instrument that took the measurements, date/time of the first and the last acquisition, total number of samples in the file.

To open the measurements file, double click on the file name, or select the file and click with the right key of your mouse, then select Explore.

To select acquisition sessions saved outside the default folder, select the Tree view of the directory command and then indicate the path containing the measurements file.

In alternative, select the View Data icon in the command bar, or else the  View Data item of the File menu, then select the desired file and press Open.

Following the data file opening, the window below will appear:

The list of the detected quantities and the color of the corresponding graphs appears in the upper left panel. The measurements acquired in tabular form are listed in the upper right panel.

When opening the window, only the graph concerning the first quantity of the list is displayed. To display or hide the graph concerning a certain quantity, click on the small box at the left of the quantity name in the upper left panel, in order to add a checkmark or cancel it.

In the quantity list, each quantity has three items, corresponding to the three values that appear in the Monitor window: AVG (mean value of the measurement in the storage interval), MIN (minimum measurement value in the storage interval) and MAX (maximum measurement value in the storage interval). The relevant graph for each of the three items can be displayed.

 

ZOOM FUNCTIONS

You can modify the ordinate scale of single graphs or apply a zoom to highlight particular areas in the graph region. The graph panel can be enlarged so as to make it engage the whole area of the data display window.

 

Enlargement of the graph panel

Select the sixth icon from the left in the upper part of the window.

Graphs will engage the whole available area. To reduce the area occupied by the graph, select again the same icon.

 

Modifying the scale

On the right side of the upper left panel, select the quantity whose scale you want to modify.

Select X1 to change the scale in steps of 1unit, or  X10 to change it in steps of 10 units.

Then:

select the arrow keys to scroll the scale up or down.

select "+" and "-" keys to decrease or increase the maximum scale of the ordinate axis.

change values in Max and Min fields to set precisely minimum and maximum scale limits.

 

Zoom

To enlarge an area in the graph, press a point on the area border with the left key of your mouse and, keeping the key depressed, drag the mouse pointer to draw a window around the area of interest, then release the key.

The selected region will now engage the whole graph area.

If your mouse is supplied with a scroll wheel, the graph can be enlarged or reduced also moving the wheel backward or forward.

To return to the previous zoom dimensions, click with the right key of your mouse to display the following list of commands:

then select:

Un-Zoom: to return to the previous zoom dimensions.

Undo All Zoom/Pan: to return to the initial graph display.

These commands are enabled only if a zoom function has been applied to the graph

In addition to cancel-zoom functions, also the following commands can be made available by clicking with the right key of your mouse:  

Copy: copies the graph in the "Notes".

Save Image As...: saves the graph as "bitmap" image in "emf", "png", "gif", "jpg", "tif" or "bmp" formats.

Page setup: allows to set the page format for the graph print.

Print: prints the graph.

Show Point Values: enables or disables display of acquired measurements when pointing the mouse on a point of the graph trends.

Set Scale to Default: fits the vertical scale to measured values, that is applies the maximum zoom level that allows complete display of trends.

 

CUSTOMIZING GRAPHS

The background color of graphs, the axis color, the color and line thickness of single graphs can be changed.

 

Change background color

Select the fourth icon on the left on top of the window.

Select the desired color in the displayed color table and press OK.

 

Change axis color

Select the third icon on the left on top of the window.

Select the desired color in the displayed color table and press OK.

 

Change the line thickness of graphs

Select the fifth icon on the left on top of the window.

Select Increase lines thickness or Decrease lines thickness to enlarge or reduce graph lines.

 

Change the color of graphs

Select the colored bar next to the quantity name.

Select the desired color in the displayed color table and press OK.

 

PRINTING DATA

The displayed data can be printed by selecting the first icon on the left on top of the window.

Data are printed in the tabular form that appears in the upper right panel.

 

EXPORTING DATA

The displayed data can be exported in Excel format by selecting the second icon on the left on top of the window.

A message confirming the completion of the export operation is displayed after a few seconds, indicating the folder where the file has been saved. The exported file is created in the same folder of the source data file.

 

DELETING A FILE

If you wish to delete a file, select it in the program main window and click with the right key of your mouse, then select Delete.

 

 

UPDATING FOLDER CONTENT

If the folder content is not updated following a file cancellation or creation, select the Refresh command that is displayed by clicking with the right key of your mouse in the file window, or select the Refresh icon in the command bar.

 

 

ERRORS

The Errors column in the left upper panel shows all measurement acquisition errors. To display the list of quantity-related errors, select the corresponding  Errors field.

The red number at the right of the field indicates the total number of errors occurred during the acquisition of the corresponding quantity.

Selecting a line of the error list, the line with the selected error is automatically highlighted in the measurement data table.

 


Info on the instrument

Select the Instrument Info item in the Tools menu, to display info concerning the connected instrument.

A window will appear showing, in the order, instrument model, serial number, firmware version, user code and date of the last calibration.

Press OK to return to the software main window.


Software language

To change the software language, select the Language item in the Help menu, then choose the desired language.

 


Info on the software

Select the Help menu to obtain additional info on software version and license terms, as well as to open the program manual.

On-line Help can be opened quickly by selecting the icon marked with a question mark in the command bar.

 


Updating the firmware

The firmware of the instrument can be updated through the Firmware Loader function in the Instruments menu.

Procedure:

1. Connect the instrument to the computer where the HD52.3D-S program is installed.

2. Turn on the instrument and set it in configuration mode.

3. In the Tools menu, select the Firmware Loader item.

Note: the Firmware Loader item is disabled if a connection is in progress; in this case, select the Disconnect icon to terminate the connection and enable the Firmware Loader item.

4. Select the number of the computer COM port the instrument is connected to. Set the Baud Rate to 115200 and select 8N2 option.

5. With the Browse... key, select the update file that was previously copied in a folder of your computer.

6. Press the Start key to start updating.

7. Upon completion of the file upload, a message will be displayed for a few seconds informing that the update was performed successfully. At the end of the operation, press the Exit key.

Updating is concluded.

ATTENTION : it is possible to update the firmware with the RS232 or USB connection only.

 


Command icons

Connect
Connects the instrument to the computer (available only if the instrument is not connected).

Disconnect
Disconnects the instrument from the computer (available only if the instrument is connected
View Data
Opens a data file saved in the computer.
Monitor
Acquires the measurements of the instrument connected to the computer in real time.
Tilt (°)
Displays the tilt and compass measurements in the HD51.3D... models equipped with the optional sensor.
Instrument settings
Configures the instrument operation parameters.
Refresh
Updates the content of folders.
Language
Selects the software language.
Help
Opens the program manual.
Exit
Closes the opened program or window.

 


Menu commands

File >> View Data: displays data files saved in the computer.

File >> Start monitor: starts Monitor function.

File >> Monitor setup: configures the Monitor function.

File >> Exit: closes the program.

 

Tools >> Serial Connection: sets parameters for computer connection.

Tools >> Connect: connects the instrument to the computer (command active only if the instrument is not connected).

Tools >> Disconnect: disconnects the instrument from the computer (command active only if the instrument is connected).

Tools >> Instrument settings: configuration of instrument operation parameters.

Tools >> Instrument Info: displays info on the connected instrument.

Tools >> Predefined folder: sets the path of the working folder where data are saved.

Tools >> Firmware Loader:updates the firmware.

 

View >> Toolbar: enables or disables display of command icons.

View >> Status Bar: enables or disables info display in the status bar.

View >> Tree View: enables or disables display of the folders window.

View >> View details: displays the list of files in the folders with date, dimension and type of file.

View >> View icons: displays the list of files in the folders as icons, with no file details. 

 

Help >> HD52.3D-S Manual: opens the program manual.

Help >> HD52.3D-S License: displays the license of use of the program.

Help >> Language: selects the software language.

Help >> About...: displays the program version.


08-01-2024