HD32MTLogger Software Manual for the instrument HD2013-DB Introduction
The HD32MTLogger program allows management of the HD2013-DB datalogger from your PC.
Using this software you can manage:
• datalogger configuration;
• data transfer to PC;
• graphic presentation and printing of captured measurements;
• display of measurements in real time, also graphically.
The data logged in the instrument internal
memory can be downloaded on the PC, saved on file, printed, and exported in
Excel.
The software has an automatic search function of the devices connected to the PC.
For the instrument complete features, please see the printed manual or the PDF file available in the Documentation section of the CD-ROM.
Start the application by double clicking on the application icon on the desktop, or select the HD32MTLogger item in the DeltaOhm folder on the Start menu.
If you have an Internet connection, the program first checks for a new software update asking if you wish to install it. If no Internet connection is detected or no software update is available, the warning is not displayed and the main page appears.

You can see the following areas:
1. Menu: it collects the menu items.
2. Command Bar: a set of icons of the main commands of the application.
3. Folder Window: it displays the PC folders and the default work folder.
4. Properties Window: shows the characteristics of the file selected in the File Window (point 5).
5. File Window: all files contained in the folder selected in the Folder Window (point 3).
6. Status Bar: provides information on the serial connection and the connected instrument.
7. Measurement window: displays the rain quantity in real time.
The areas can be resized by dragging the borders with your mouse.
The use of the application sections and available commands is illustrated in detail in the following paragraphs. At the end of the manual you can find the complete list of commands with a short description, in order to provide a quick guide to the various functions.
1. Connect the datalogger to the PC using the HD2110RS (RS232) or CP25 (USB) cable.
2. Select the Serial Connection item in the Tools menu to configure the connection.

3. In the Connection Properties window, ensure the RadioModem option is not checked, or click on the small box near the item to deselect it (the Radio Modem connection is not available for the model HD2013-DB). Select the number of the COM port of the PC to which the instrument is connected, then press Apply to return to the main window. If the port number is unknown, do not change the setting and press Apply to exit. The program will automatically search for an instrument connected to the PC's available ports, starting from the set one. The remaining communication parameters cannot be changed.

4. Select the Choice of instrument model and connection type item in the Tools menu.

5. Select the model HD2013-DB and the Serial connection option (the TCP/IP connection is not available for the model HD2013-DB). Press Apply to store the choice. Press Exit to return to the main window.

6. Make sure the instrument is switched on, then select the Connect icon in the Command Bar, or the Connect item in the Tools menu.

If the connection is successful, the software displays the DataLogger Information window with datalogger model, serial number, firmware version and user code.

Press OK to access the software's main window. If OK is not pressed, the window will automatically close after 10 seconds. Later, the DataLogger Information window can be opened from the main window by selecting Tools >> Instrument info.
A correct connection is indicated by a green label on the left of the status bar. In the status bar are also shown, in this order: current date and time, battery level, backlight state, datalogger model, serial number, firmware version, user code and rain gauge resolution.
![]()
If the connection fails, an error message is shown; in such case, check the serial connection's cables and settings.
At the end of the connection, before removal of the cables, select the Disconnect icon in the Command Bar, or the Disconnect item in the Tools menu.

The software, during installation, creates the Deltaohm\HD32MTLogger default work folder in the installation disk's root.

To change the work folder name and position, you can use the Predefined folder command in the Tools menu.

The following window opens:

Press Change... and select the new folder, then confirm with OK.
Press Apply to close the window. To have the change take effect, you need to close and restart the application.

To update the date and time of the instrument, select the Clock Setup icon in the Command Bar, or the Clock Setup item in the Tools menu.
You will get a message to remind that updating the clock could lead to inconsistencies between date/time of the data recorded before and date/time of the data recorded after the clock updating. Press Yes to continue.
Enter the password and press Apply (the password cannot be changed by the user and is written in the file "PW_HD2013DB.pdf" available in the PDF folder of the CD-ROM).

The following window will appear:

At the top of the window, under the Pluvio Logger HD2013-DB title, you can see the datalogger date and time.
Select the option "day-month-year" (DD/MM/YYY) or "year-month-day" (YYYY/MM/DD) for the date.
Enter the new date and time in the fields at the bottom of the window, or select PC Clock to set the instrument to the same date and time of the PC.
Press Apply to set the the date and time in the instrument. You will get a message to remind that updating the clock could lead to inconsistencies between date/time of the data recorded before and date/time of the data recorded after the clock updating. Press Yes to continue.
Press Exit to return to the application main window.
To view and set the user code of the instrument, select the User Code Setup icon in the Command Bar, or the User Code Setup item in the Tools menu.

The following window will appear:

To modify the user code, write the new code and press Apply.
Press Exit to close the window without code changes.
The data captured by the instrument can be transferred to the PC for display and processing.
Select the Dump LOG icon in the toolbar or the Dump LOG item from the File menu.
The following window will appear:

At the top of the window are indicated:
• the number of records stored in the data logger;
• the date of the oldest record;
• the date of the most recent record;
• the number of records stored after the last download.
Select Browse, then indicate the folder and the name of the file (with extension d32) in which to save the data.
Indicate if you wish to download all data in the memory (All Data option) or only those recorded after the last download (New Data option).
To also save the data in the "CSV" format (that can be imported in Excel), select the Create .csv file box. The box is checked by default.
To start the data transfer press Start.
The transfer status is indicated by a progress bar at the bottom of the window. You can cancel the transfer pressing Abort.

At the end of the transfer, press OK to return to the Data download window.

The file concerning the downloaded data will be listed in the folder indicated when saving.

Values measured by the instrument are displayed in real time in the program main window.

In the window are indicated numerically:
• the number of records stored in the data logger;
• the number of records stored after the last download;
• the date of the oldest record;
• the date of the most recent record;
• the total rain in mm (rain quantity after the total counter reset);
• the partial rain in mm (rain quantity after the partial counter reset);
and graphically:
• the rain quantity in the last hour;
• the rain quantity in the last 4 hours;
• the rain quantity in the last 24 hours;
• the rain quantity in the last 48 hours;
• the rain quantity in the last 72 hours;
• the rain quantity in the last 96 hours.
If the correction table is enabled, both the uncompensated and the compensated total rain and partial rain values are indicated numerically. For the details about the use of the correction table, see the Setup paragraph.

To change the full scale of the graphs, modify the value of the field at the top left of the pane.

To reset the total and partial counter, see the Setup paragraph.
View and export the saved data
The data downloaded from the datalogger and saved in the PC can be directly recalled and analyzed with the HD32MTLogger program, or exported in Excel format.
To recall the data saved on the PC, select the file containing the data to be displayed.

In the Description of selected file box you can view the quantities in the file. At the bottom of the box, the complete path, recording interval, date and time of the first and last acquisition, total number of samples present in the file are indicated.
To open the file of the measurements double click on the name of the file, or select the file and click with the right button of the mouse, then select Explore.

To select the acquisition sessions saved outside the default folder, select the Tree view of the directory command and indicate the path of the measurement file.

As an alternative, select the View Data icon in the toolbar, or the View Data item in the File menu, then select the desired file and press Open.

When the file is opened, two windows appear:
• "data processing" window;
• "switching instants of the rain gauge tipping bucket" window.
Data processing window

At the bottom of the window, the selected time, the date and time of the first and last record are indicated.
The selected time is divided into intervals with duration equal to the value of the filed at the top of the window (for example, 1 hour in the figure). The amount of rain that fell in each interval is shown numerically in the top pane, and graphically in the bottom pane of the window. If the correction table is enabled, the amount of rain is the one compensated.
To change the data processing interval, select the filed at the top of the window and choose a different value.

To change the selected time (x-axis of the graph), enter start date/time (fields From) and end date/time (fields To), then press Graph.

The data can be exported in Excel format by selecting, in the upper side of the window, the button Export excel. The exported file is created in the folder "32MTLogger\graph".

Switching instants of the rain gauge tipping bucket window

In the upper left box, the detected quantity and the correspondent graph colour will appear. The upper right box displays the switching instants of the rain gauge tipping bucket and the instrument resolution. If the correction table is enabled, the resolution is the one compensated. The graph shows the value of the resolution (the value is constant if the correction table is disabled).
In the Errors column, in the upper left panel, the acquisition errors are reported. To view the errors list, select the Errors filed.
The displayed data can be printed by selecting, in the upper side of the window, the first icon from the left, then the Print data item. The data are printed in the table format that appears in the upper right panel.

The displayed data can be exported in Excel format by selecting, in the upper side of the window, the second icon from the left. After some seconds you will get a message confirming the export completion, with indication of the saving folder. The exported file is created in the folder "32MTLogger\graph".

The zoom, calculation, graph customization and report print functions available in the window are not significant for the model HD2013-DB. To use such features, see the HD32MTLogger software manual for the model HD32MT.1.
Deleting files
If you wish to remove a file, select it in the application main window, click with the right button of the mouse, then select Delete.

Updating the folders content
If the folder content is not updated after removal, creation or download of files, click with the right button of the mouse in the files window and use the Refresh command, or select the Refresh icon in the toolbar.

Select the Setup icon in the toolbar or the Setup item from the Tools menu.
The following window will appear:

In the Setup window the following operations can be performed:
• set the rain gauge resolution;
• reset the total rain counter;
• reset the partial rain counter;
• restore the datalogger parameters to default values;
• erase the data logger memory;
• set the data logger language;
• set and enable the correction table as a function of the rainfall rate.
Set the rain gauge resolution
Enter the value you want to set in the Resolution field.

Changing the value of the parameter, a green circle appears on the right side of the window. Select Execute to apply the new setting.

You will be prompted to confirm the operation, press Yes to continue.
Reset the total rain counter
The reset of the Total rain counter is used to measure the amount of rainfall starting from the reset time.
Select the Full reset check box.

Selecting the check box, a green circle appears on the right side of the window. Select Execute to reset the counter.

You will be prompted to confirm the operation, press Yes to continue.
The reset of the Total rain counter also causes the reset of the Partial rain counter.
The counter reset does not erase the data stored in memory and has no effect on the graphs in the main window.
Reset the partial rain counter
The reset of the Partial rain counter is used to measure the amount of rainfall starting from the reset time.
Select the Partial reset check box.

Selecting the check box, a green circle appears on the right side of the window. Select Execute to reset the counter.

You will be prompted to confirm the operation, press Yes to continue.
The counter reset does not erase the data stored in memory and has no effect on the graphs in the main window.
Restore the datalogger parameters to default values
The rain gauge resolution, the data logger language and the date format can be set to factory configuration.
Select the Set defaults check box.

Selecting the check box, a green circle appears on the right side of the window. Select Execute to apply the factory configuration.

You will be prompted to confirm the operation, press Yes to continue.
Erase the data logger memory
Select the Erase memory check box.

Selecting the check box, a green circle appears on the right side of the window. Select Execute to erase the memory.

You will be prompted to confirm the operation, press Yes to continue.
Set the data logger language
Select the language you want to set from the drop down list.

Selecting a language, a green circle appears on the right side of the window. Select Execute to apply the setting.

You will be prompted to confirm the operation, press Yes to continue.
Correction table as a function of the rainfall rate
If the rain gauge connected to the data logger has a measurement correction table as a function of the rainfall rate, it is possible to store the correction in the data logger and also display the total and partial rain compensated values.
Note: the correction is not applied to the values of quantity of rain in 1h, 4h, 24h, 48h, 72h and 96h.
By default, the correction is disabled. In order to enable the correction, it is necessary to put a check mark in the field Enable rain correction.

Then you need to enter the correction values in the table below (by default, the correction values are set to zero).

For each row in the table, enter the percentage of correction to be applied when the interval between two subsequent pulses of the rain gauge tipping bucket is lower than the time indicated. For example, in the row Correction interval lower than 5 seconds, enter the correction to be applied when the rainfall rate is such as to generate two subsequent pulses in less than 5 seconds.
The correction is added to the resolution of the rain gauge. For example, if a rain gauge with 0.200 mm resolution is used, and in the row Correction interval lower than 5 seconds 4% is set, the rain gauge resolution will be considered 0.208 mm when the rainfall rate is such as to generate two subsequent pulses in less than 5 seconds.
Negative correction values can be entered, in order to have rain gauge resolutions lower than the nominal resolution. The maximum correction value that can be set is 20%.
If, in the technical data of the rain gauge, the correction is expressed as a function of the hourly rainfall rate (in mm/h or inches/h depending on the unit of measurement used), use the following formula to calculate the interval, in seconds, among the pulses as a function of the rate:
Interval = 3600 * Corrected resolution / Rate
For example, if a rain gauge with 0.200 mm nominal resolution has a resolution of 0.208 at 100 mm/h (and therefore a correction factor of +4%), the interval among the pulses is:
Interval = 3600 * 0.208 / 100 = 7.49 seconds
Therefore, at 100 mm/h will be applied the correction set in the field Correction interval lower than 8 seconds.
As an alternative, the corrections can be set to a first approximation in a simplified manner by following the correspondence between the interval of the pulses and the rainfall rate indicated in the table that follows, where R is the nominal resolution of the rain gauge used (the method is approximated because it considers the nominal resolution instead of the compensated resolution; typically, however, the reported hourly rate values are not far from the real values).
| Interval | Pulses
/ hour |
Hourly
rainfall rate Resolution = R |
Hourly
rainfall rate Resolution = 0.2 mm |
|---|---|---|---|
| lower
than 2 s |
greater
than 1800 |
greater than 1800 * R | greater than 360 mm/h |
| lower than 3 s | greater
than 1200 |
greater than 1200 * R | greater than 240 mm/h |
| lower than 4 s | greater than 900 | greater than 900 * R | greater than 180 mm/h |
| lower than 5 s | greater than 720 | greater than 720 * R | greater than 144 mm/h |
| lower than 6 s | greater than 600 | greater than 600 * R | greater than 120 mm/h |
| lower
than 8 s |
greater than 450 | greater than 450 * R | greater than 90 mm/h |
| lower
than 10 s |
greater than 360 | greater than 360 * R | greater than 72 mm/h |
| lower
than 15 s |
greater than 240 | greater than 240 * R | greater than 48 mm/h |
| lower
than 30 s |
greater than 120 | greater than 120 * R | greater than 24 mm/h |
Select Execute to apply the correction.

You will be prompted to confirm the operation, press Yes to continue.
Saving settings in your computer
Select the Save key to save the values of the set parameters in a configuration file (in txt format) in your computer.

Opening of an existing configuration file.
Select the Open key to upload the values regarding a previously saved configuration in the Setup window.

Then select the desired configuration file and press Open.
To close the Setup window, press the Exit button.
To change the software language, select the Language item in the Help menu, then choose the desired language.

For further information about the software version and license terms, and to open the program manual, select the Help menu.

The online Help can be opened quickly by selecting the question mark icon in the toolbar.

The program (firmware) that manages the datalogger
can be updated using the function HD2013-DB Firmware Loader in the Tools
menu.
To request firmware updates, if available, please contact Delta Ohm.
Procedure:
1. Using the HD2110RS (RS232) or CP25 (USB) cable, connect the datalogger to the computer in which the HD32MTLogger software is installed.
2. Turn the instrument on.
3. In the Tools menu , select HD2013-DB Firmware Loader.

4. Select the number of the COM port of the PC to which the instrument is connected and set the Baud Rate to 115200.

5. Use the Browse... button to select the update file with extension " bin " copied into a PC folder.

6. To start updating, press Start.

7. Wait for the message informing that the update was performed successfully.
8. At the end of the operation, press the Exit key.
![]() |
Connect |
|
|---|---|---|
![]() |
Disconnect It disconnects the datalogger from the PC (available only if the instrument is connected). |
|
![]() |
View Data It opens a data file saved in the PC. |
|
![]() |
Dump LOG it transfers to the PC the data stored in the instrument. |
|
![]() |
User Code Setup Viewing and setting of the user code. |
|
![]() |
Clock Setup Setting of the instrument date and time. |
|
![]() |
Setup Configuration of the datalogger. |
|
![]() |
Import Function used with HD32MT.1 model. |
|
![]() |
Service Function used with HD32MT.1 model. |
|
![]() |
Refresh It updates the folder contents. |
|
![]() |
Help It opens the program manual. |
|
![]() |
Exit It closes the application or the open window. |
Menu items
File >> View Data: view of data files saved in the PC.
File >> Dump LOG: transfer to the PC of the data stored in the datalogger.
File >> Exit: close the program.
Tool >> Serial Connection: setting the PC direct serial connection parameters.
Tool >> TCP/IP Connection setup: only for model HD32MT.1.
Tool >> Choice of instrument model and connection type: selection of data logger model and serial connection type.
Tool >> Connect: connecting the datalogger to the PC (command available only if the datalogger is disconnected).
Tool >> Disconnect: disconnecting the datalogger from the PC (command available only if the datalogger is connected).
Tool >> Clock Setup: setting the instrument date and time.
Tool >> User Code Setup: wiewing and setting the user code.
Tool >> Setup: configuration of the datalogger.
Tool >> Import: function used with HD32MT.1 model.
Tool >> Instrument info: viewing the information for the connected instrument.
Tool >> Predefined folder: setting of the work folder path to which the data are saved.
Tool >> HD2013-DB Firmware Loader: updating of the datalogger firmware.
View >> Toolbar: enabling or disabling the display of command icons.
View >> Status Bar: enabling or disabling the display of status bar information.
View >> Tree View: enabling or disabling the display of the Folder Window.
View >> View details: viewing of the list of files in the folders with date, size and type of file.
View >> View icons: viewing of the list of files in the folders as icons, without file details.
Help >> 32MTLogger Manual: opening of the program manual.
Help >> 32MTLogger License: viewing of the program user license.
Help >> Language: selects the software language.
Help >> About...: viewing of the program version.
02-02-2017